Setup

Welcome!

Introducing 电子游戏平台官网 Teacher Training, a resource library to help you integrate 电子游戏平台官网 in the classroom. Learn about the power of tangible play, and the best ways for your school to activate and engage with 电子游戏平台官网.

my电子游戏平台官网 Profiles

Learn how to use my电子游戏平台官网 to save data for multiple kids, track progress, reset progress, and more.

电子游戏平台官网 Compatibility

电子游戏平台官网 is compatible with most iPads and select Amazon Fire tablets.

iPads

Full Compatibility

  • iPad (Generations 5, 6, 7, 8)
  • iPad Mini (Generations 2, 3, 4, 5)
  • iPad Air (Generations 1, 2, 3, 4, 5)
  • iPad Pro 9.7-inch
  • iPad Pro 10.5-inch
  • iPad Pro 11-inch (Generations 1, 2, 3)
  • iPad Pro 12.9-inch (Generations 1, 2, 3, 4, 5)

Limited Compatibility*

  • iPad 2
  • iPad 3
  • iPad 4
  • iPad Mini 1

*The limited compatibility iPads are no longer compatible with 电子游戏平台官网, no longer being supported, and are considered obsolete by Apple.

If you have previously downloaded 电子游戏平台官网 apps on one of these devices, they should continue to work. However, they will not receive new updates or content and if you delete the app, you will not be able to download it again. As a result, we are limited in our ability to provide technical support for these models.
iOS Version: The minimum iOS version required is 11

Amazon Fire tablets

Full Compatibility

  • Amazon Fire HD 8 (8th Generation)
  • Amazon Fire HD 10 (9th Generation)
  • Amazon Fire HD 8 (10th Generation)
  • Amazon Fire HD 10 (11th Generation)

Limited Compatibility*

  • Amazon Fire 7 (7th Generation)
  • Amazon Fire 7 (9th Generation)
  • Amazon Fire HD 8 (7th Generation)
  • Amazon Fire HD 10 (7th Generation)

*The limited compatibility Fire Tablets are no longer compatible with 电子游戏平台官网, and are no longer being supported by Amazon.

If you have previously downloaded 电子游戏平台官网 apps on one of these devices, they should continue to work. However, they will not receive new updates or content and if you delete the app, you will not be able to download it again. As a result, we are limited in our ability to provide technical support for these models.
Fire OS Version: The minimum Fire OS version required is 7.0